Troubleshooting and Repair of an LCD TV

Well, that was a fun week I’ve just had! We are looking to have a video slide show in the church lobby for bulletins and the like, running from a Raspberry Pi Zero W miniature computer. To that end, I picked up a couple of broken TVs from Kijiji in the hopes I could get them to work.
 

Summary

Insignia 50″ TV… works well, except for when it doesn’t. Which is most of the time.

The purchase: 50 inch Insignia NS-50D40SNA14, for $40. (I also purchased a 60 inch Sony Bravia KDL-60EX720 from the same seller for an additional $50, but that’s a story for a different post.)

The problem: The Insignia shows a great image… for about 3-4 minutes. Then it goes completely dark. If it’s powered up immediately afterward, it will shut down within seconds.

Here’s the story of how I got this TV to work.

 

Troubleshooting

Given the symptom, it was clear that the TV was overheating someplace. The trick was to find out where and how to fix it. So, it was time to remove the back cover and look inside.
 
The back case came off pretty easily — I just had to remove a ton of screws.

 
The back cover was now off and I could take a look.

 
Hmm. It was pretty dirty. These components weren’t looking good. Could that have been the source of the overheating?

 
Alas, it was not to be that easy. I blew out the dust and tried the TV again, encountering the same problem. None of the capacitors looked like they were obviously failing, either (that’s often a culprit in electronics problems like this). I clearly needed to keep looking.
 
I also wondered if anyone else was having a similar problem and came across a handy discussion forum. One person found that their LED driver chip was overheating. This chip is labelled “OB3362RP” and a quick look at the data sheet revealed that it does indeed have thermal protection circuitry. That looked like a promising lead.

 
As a quick test, I taped a random heatsink I had lying around to the top of the chip to see if it helped matters at all. Even though this was not at all a good situation for the heatsink, I saw a huge improvement; the TV stayed on for about 16 minutes! A 400% improvement showed me that I was on the right track.

 
But why was the chip overheating in the first place? One suggestion I saw online was that dead LEDs in the backlight may be short circuiting, drawing more current than normal. That could do it. So I took the TV entirely apart. Dozens of screws and plastic clips later, I saw this:

 
Two LEDs were clearly out. Shortly after this photo was taken, a third one went out. Oops! So I removed one LED and tried soldering a random, 5V red LED in its place to see if it would light up. It did! I realized that I could conceivably replace the nonfunctioning LEDs. Off to the electronics supply store I went…

 
…and I picked up these generic white LEDs. I wasn’t sure if they would work, but they were a whopping 54 cents a piece so it was worthwhile to try it out.

 
The verdict: It worked. Briefly. They ran brightly for about 30 seconds and then began to burn out. I assume they couldn’t handle the current. Oops.

 
Chloe was getting bored by this point.

Repair

It was time to actually try to repair this thing with proper parts. I found some surface mount LEDs designed for TV backlights online and ordered those. The pack of 12 was a whole $10. (Plus $30 shipping. Whee.)

 
The bottom side of the LED strips is copper. I had seen someone online use a clothes iron to heat up the strip enough to desolder the old LED and to solder the new one. I tried it for a while (using a wrench to hold it down), but it wasn’t hot enough to melt the solder. Hmm. What else could I use?

 
Then I remembered: I have a George Foreman Grill! Not only can it make mean, lean, fat-reduced burgers, but removing the teflon pieces revealed a great hot plate. Would this work?


 
Short answer: Yup! It discoloured the paint on the strip somewhat but it worked wonders for soldering the surface mount LEDs!

 
I used tweezers to help position the LEDs just right on the pad.

 
Once I had all three of the burned-out LEDs changed, it was time to test it out.

 
And it… did nothing. Oops. Apparently I connected the LEDs backwards. It’s, uhh, a mistake anyone could make and stuff.
 
So… I removed them and turned them around. This resulted in more discolouration on the metal strips. Betcha can’t tell which three LEDs got changed, eh?

 
I used some double-sided tape to fix the strips to the back of the TV. Similar tape was used at the factory, as far as I could tell.

 
I also glued on the lenses with epoxy. Some of them had popped off when I removed the strips, in addition to the lenses for the three LEDs I had replaced.

 
And… Voila!! It worked!

 
However: it again shut off after about 12 minutes or so. Still, it was an improvement. I wonder if either the new LEDs are drawing more current than the originals, or if perhaps the LED driver chip was damaged somehow.
 
I decided to try out a heatsink again, since it looked like the chip was running close to the thermal threshold without one. I drilled a couple of holes so that I could mount an old heatsink from a CPU that I had lying around. I also put some thermal grease onto the top of the chip.

 
Huzzah! It worked wonders; the TV stayed on for as long as I wanted it to!

 
Since the heatsink was getting pretty warm to the touch, I decided to wire up its matching fan. Fortunately, the board has a 5.1 volt pin for when the TV is on standby and the fan (designed for 12 volts) shouldn’t draw too much current. So, I wired it up to that pin.

 
Huzzah! It worked! And best of all, the heatsink was now totally cool to the touch, even after hours of operation!

 
The heatsink and fan protruded too far to have the original back piece fit. So I needed to cut out a square piece with my Dremel.

 
And then I reassembled everything…

 
Here’s how the back looks with the fan sticking out. I’m going to have to find a grill of some sort to protect the fan and heatsink.

 
And here it is! Working! Yay!

Final thoughts

For $40, plus $10 worth of LEDs (and $30 to ship them), I’m pleased with the fix. However there are several slightly brighter spots on the left side of the TV, and that’s not just where I changed the LEDs. I’m guessing I misaligned some of the lenses when I glued them back on. I’m debating taking the whole thing apart again to check it out… and I’m also thinking that it may be good enough. For the price, I really can’t complain. :)

Oh, and I also managed to get the 60″ Sony TV working. All four HDMI ports are dead but an HDMI-Component adapter works really well. I now have a huge TV in the rectory living room!

Has anyone else tried any repairs like this?

Hope I wasn’t too boring with the details… I enjoyed myself immensely as I was doing this fix!

Author: Fr. Darryl Millette

A priest of the Roman Catholic Diocese of Saskatoon.

Share This Post On

Submit a Comment

Your email address will not be published. Required fields are marked *